This page is no longer maintained — Please continue to the home page at www.scala-lang.org

Re: Sequence -> Seq

5 replies
nilskp
Joined: 2009-01-30,
User offline. Last seen 1 year 27 weeks ago.
On Tue, Sep 22, 2009 at 2:26 PM, Erik Engbrecht <erik [dot] engbrecht [at] gmail [dot] com> wrote:
Can we change BigInt to Integer, too?

That's probably too confusing. Unlike BigDecimal, there is a class without the Big.

anli
Joined: 2008-08-19,
User offline. Last seen 1 day 47 min ago.
Re: Sequence -> Seq

On Tuesday 22 September 2009 23:37:26 Erik Engbrecht wrote:
> It wouldn't be if we had Int32 and Int64 instead of Int and Long.... ;-)

Here I agree with Nils: for me Interger isn't too obvious at presence of Int.

>
> On Tue, Sep 22, 2009 at 3:33 PM, Nils Kilden-Pedersen
wrote:
> > On Tue, Sep 22, 2009 at 2:26 PM, Erik Engbrecht
wrote:
> >> Can we change BigInt to Integer, too?
> >
> > That's probably too confusing. Unlike BigDecimal, there is a class
> > without the Big.
>

Erik Engbrecht
Joined: 2008-12-19,
User offline. Last seen 3 years 18 weeks ago.
Re: Sequence -> Seq
It wouldn't be if we had Int32 and Int64 instead of Int and Long....  ;-)

On Tue, Sep 22, 2009 at 3:33 PM, Nils Kilden-Pedersen <nilskp [at] gmail [dot] com> wrote:
On Tue, Sep 22, 2009 at 2:26 PM, Erik Engbrecht <erik [dot] engbrecht [at] gmail [dot] com> wrote:
Can we change BigInt to Integer, too?

That's probably too confusing. Unlike BigDecimal, there is a class without the Big.




--
http://erikengbrecht.blogspot.com/
Kevin Wright
Joined: 2009-06-09,
User offline. Last seen 49 weeks 3 days ago.
Re: Sequence -> Seq
While we're at it... Is anyone up for renaming mkString to makeString?
:)

On Tue, Sep 22, 2009 at 8:40 PM, Andrew Gaydenko <a [at] gaydenko [dot] com> wrote:
On Tuesday 22 September 2009 23:37:26 Erik Engbrecht wrote:
> It wouldn't be if we had Int32 and Int64 instead of Int and Long....  ;-)

Here I agree with Nils: for me Interger isn't too obvious at presence of Int.


>
> On Tue, Sep 22, 2009 at 3:33 PM, Nils Kilden-Pedersen
<nilskp [at] gmail [dot] com>wrote:
> > On Tue, Sep 22, 2009 at 2:26 PM, Erik Engbrecht
<erik [dot] engbrecht [at] gmail [dot] com>wrote:
> >> Can we change BigInt to Integer, too?
> >
> > That's probably too confusing. Unlike BigDecimal, there is a class
> > without the Big.
>

Viktor Klang
Joined: 2008-12-17,
User offline. Last seen 1 year 27 weeks ago.
Re: Sequence -> Seq


On Tue, Sep 22, 2009 at 9:57 PM, Nils Kilden-Pedersen <nilskp [at] gmail [dot] com> wrote:
On Tue, Sep 22, 2009 at 2:43 PM, Kevin Wright <kev [dot] lee [dot] wright [at] googlemail [dot] com> wrote:
While we're at it... Is anyone up for renaming mkString to makeString?

Now that would just be gratuitous.

Take a walk on the wild side and rename it to "asText" ;-)


--
Viktor Klang

Blog: klangism.blogspot.com
Twttr: viktorklang

Lift Committer - liftweb.com
AKKA Committer - akkasource.org
Cassidy - github.com/viktorklang/Cassidy.git
SoftPub founder: http://groups.google.com/group/softpub
nilskp
Joined: 2009-01-30,
User offline. Last seen 1 year 27 weeks ago.
Re: Sequence -> Seq
On Tue, Sep 22, 2009 at 2:43 PM, Kevin Wright <kev [dot] lee [dot] wright [at] googlemail [dot] com> wrote:
While we're at it... Is anyone up for renaming mkString to makeString?

Now that would just be gratuitous.

Copyright © 2012 École Polytechnique Fédérale de Lausanne (EPFL), Lausanne, Switzerland