This page is no longer maintained — Please continue to the home page at www.scala-lang.org

Eclipse IDE for Scala 2.0.0-beta5 with Scala 2.9.0-1 and 2.8.x ready for download!

4 replies
Iulian Dragos
Joined: 2008-12-18,
User offline. Last seen 42 years 45 weeks ago.
We are happy to announce that the beta5 release of the Eclipse IDE forScala is ready for download! This release comes in two flavors: the2.9.0-1 version, and the 2.8.2-SNAPSHOT version. That's right, for the first time in the 2.0.0 branch, we have a build of the Scala pluginthat's compatible with 2.8!
The 2.8 compiler shipped with this version of the plugin is based on the development branch of 2.8.2, and is fully binary compatible with2.8.1. It contains the same improvements to the presentation compileras the 2.9 version, and a number of bug fixes related to Java signatures.
You can install the new release by pointing Eclipse to the followingupdate site:
* for the 2.9.0-1 version:    http://download.scala-ide.org/releases-28/2.0.0-beta
* for the 2.8.2 version:    http://download.scala-ide.org/releases-28/2.0.0-beta
Other releases can be found at:
http://download.scala-ide.org
As all previous releases, both plugins require Eclipse 3.6 (Helios).

--
« Je déteste la montagne, ça cache le paysage »
Alphonse Allais
milessabin
Joined: 2008-08-11,
User offline. Last seen 33 weeks 3 days ago.
Re: [scala-ide-dev] Eclipse IDE for Scala 2.0.0-beta5 with Scala

On Thu, Jun 2, 2011 at 3:26 PM, iulian dragos wrote:
> * for the 2.9.0-1 version:
>     http://download.scala-ide.org/releases-28/2.0.0-beta

That should be,

http://download.scala-ide.org/releases-29/2.0.0-beta

Cheers,

Miles

hedefalk
Joined: 2008-09-24,
User offline. Last seen 1 year 5 weeks ago.
Ang.: Eclipse IDE for Scala 2.0.0-beta5 with Scala 2.9.0-1 and 2
I'm upgrading from the 2.8 wip_backport-branch to the 2.8-release. I get the following conflict:
Cannot complete the install because of a conflicting dependency.  Software being installed: JDT Weaving for Scala 2.0.0.201106012319-beta5-28-7dd4324 (org.scala-ide.sdt.weaving.feature.feature.group 2.0.0.201106012319-beta5-28-7dd4324)  Software currently installed: Eclipse Weaving Service Feature 2.1.1.e35x-release-20101021-0900 (org.eclipse.contribution.weaving.feature.group 2.1.1.e35x-release-20101021-0900)  Only one of the following can be installed at once:     JDT Weaving 2.1.1.e35x-release-20101021-0900 (org.eclipse.contribution.weaving.jdt 2.1.1.e35x-release-20101021-0900)    JDT Weaving 2.1.3.e36x-20110510-1300 (org.eclipse.contribution.weaving.jdt 2.1.3.e36x-20110510-1300)  Cannot satisfy dependency:    From: Eclipse Weaving Service Feature 2.1.1.e35x-release-20101021-0900 (org.eclipse.contribution.weaving.feature.group 2.1.1.e35x-release-20101021-0900)    To: org.eclipse.contribution.weaving.jdt [2.1.1.e35x-release-20101021-0900]  Cannot satisfy dependency:    From: JDT Weaving for Scala 2.0.0.201106012319-beta5-28-7dd4324 (org.scala-ide.sdt.weaving.feature.feature.group 2.0.0.201106012319-beta5-28-7dd4324)    To: org.eclipse.contribution.weaving.jdt [2.1.3.e36x-20110510-1300]

I need the Weaving for Scala bundled with the plugin, right? Do I need to manually uninstall the 2.1.3-version then?
Iulian Dragos
Joined: 2008-12-18,
User offline. Last seen 42 years 45 weeks ago.
Re: [scala-ide-user] Ang.: Eclipse IDE for Scala 2.0.0-beta5 wit


On Thu, Jun 2, 2011 at 10:39 PM, Viktor Hedefalk <hedefalk [at] gmail [dot] com> wrote:
I'm upgrading from the 2.8 wip_backport-branch to the 2.8-release. I get the following conflict:
Cannot complete the install because of a conflicting dependency.  Software being installed: JDT Weaving for Scala 2.0.0.201106012319-beta5-28-7dd4324 (org.scala-ide.sdt.weaving.feature.feature.group 2.0.0.201106012319-beta5-28-7dd4324)   Software currently installed: Eclipse Weaving Service Feature 2.1.1.e35x-release-20101021-0900 (org.eclipse.contribution.weaving.feature.group 2.1.1.e35x-release-20101021-0900)  Only one of the following can be installed at once:      JDT Weaving 2.1.1.e35x-release-20101021-0900 (org.eclipse.contribution.weaving.jdt 2.1.1.e35x-release-20101021-0900)    JDT Weaving 2.1.3.e36x-20110510-1300 (org.eclipse.contribution.weaving.jdt 2.1.3.e36x-20110510-1300)   Cannot satisfy dependency:    From: Eclipse Weaving Service Feature 2.1.1.e35x-release-20101021-0900 (org.eclipse.contribution.weaving.feature.group 2.1.1.e35x-release-20101021-0900)    To: org.eclipse.contribution.weaving.jdt [2.1.1.e35x-release-20101021-0900]   Cannot satisfy dependency:    From: JDT Weaving for Scala 2.0.0.201106012319-beta5-28-7dd4324 (org.scala-ide.sdt.weaving.feature.feature.group 2.0.0.201106012319-beta5-28-7dd4324)    To: org.eclipse.contribution.weaving.jdt [2.1.3.e36x-20110510-1300]

I need the Weaving for Scala bundled with the plugin, right? Do I need to manually uninstall the 2.1.3-version then?

Did you try installing the plugin without the JDT weaving that comes with it? I believe it should work, if you already have it installed.
iulian 


--
« Je déteste la montagne, ça cache le paysage »
Alphonse Allais
hedefalk
Joined: 2008-09-24,
User offline. Last seen 1 year 5 weeks ago.
Ang.: Re: [scala-ide-user] Ang.: Eclipse IDE for Scala 2.0.0-bet
Yeah, it's seems to be working :)

Copyright © 2012 École Polytechnique Fédérale de Lausanne (EPFL), Lausanne, Switzerland