This page is no longer maintained — Please continue to the home page at www.scala-lang.org

The Scala IDE for Eclipse for Scala beta 2 available now!

2 replies
Iulian Dragos
Joined: 2008-12-18,
User offline. Last seen 42 years 45 weeks ago.
We are happy to announce that, less than three weeks after the first
beta release, we take a second step towards a 2.0 release of the Scala
IDE for Eclipse. This release fixes a number of issues, such as:

* Fixes various crashes in the structure builder, leading to
un-editable files in Eclipse
* Correctly saves preferences for the diagnostics window
* Correctly show bean getters/setters in mixed Java/Scala projects
* Performance improvements in structured selection
* New formatter preference window, with preview
* Format selection only
* Better memory usage when closing projects
* Allow compiler plugins in the presentation compiler
* other bug fixes

There are 15 tickets fixed since the first beta. The complete list is
available here:

https://scala-ide-portfolio.assembla.com/spaces/ae55a-oWSr36hpeJe5avMc/tickets/report/u33405

You can install the new release by pointing Eclipse to the following
update site:
http://download.scala-ide.org/releases/wip_experiment-2.0.0-beta2

As the previous release, this one is built against the 2.9.0 branch of the Scala compiler and requires at least Eclipse 3.6 (Helios)

--
« Je déteste la montagne, ça cache le paysage »
Alphonse Allais
rytz
Joined: 2008-07-01,
User offline. Last seen 45 weeks 5 days ago.
Re: [scala-ide-user] The Scala IDE for Eclipse for Scala beta 2


On Thu, Apr 14, 2011 at 16:28, iulian dragos <jaguarul [at] gmail [dot] com> wrote:
We are happy to announce that, less than three weeks after the first
beta release, we take a second step towards a 2.0 release of the Scala
IDE for Eclipse. This release fixes a number of issues, such as:

* Fixes various crashes in the structure builder, leading to
un-editable files in Eclipse
* Correctly saves preferences for the diagnostics window
* Correctly show bean getters/setters in mixed Java/Scala projects
* Performance improvements in structured selection
* New formatter preference window, with preview
* Format selection only
* Better memory usage when closing projects
* Allow compiler plugins in the presentation compiler
* other bug fixes

There are 15 tickets fixed since the first beta. The complete list is
available here:

https://scala-ide-portfolio.assembla.com/spaces/ae55a-oWSr36hpeJe5avMc/tickets/report/u33405

You can install the new release by pointing Eclipse to the following
update site:
http://download.scala-ide.org/releases/wip_experiment-2.0.0-beta2

There seems to be something wrong. I installed from this update site, but then got the "beta1". If youcheck the "site.xml" file, it also says "beta1".
Lukas 


As the previous release, this one is built against the 2.9.0 branch of the Scala compiler and requires at least Eclipse 3.6 (Helios)

--
« Je déteste la montagne, ça cache le paysage »
Alphonse Allais

milessabin
Joined: 2008-08-11,
User offline. Last seen 33 weeks 3 days ago.
Re: [scala-ide-dev] Re: [scala-ide-user] The Scala IDE for Eclip

Glitch at my end ... try it again now ...

Cheers,

Miles

On Thu, Apr 14, 2011 at 4:17 PM, Lukas Rytz wrote:
>
>
> On Thu, Apr 14, 2011 at 16:28, iulian dragos wrote:
>>
>> We are happy to announce that, less than three weeks after the first
>> beta release, we take a second step towards a 2.0 release of the Scala
>> IDE for Eclipse. This release fixes a number of issues, such as:
>>
>> * Fixes various crashes in the structure builder, leading to
>> un-editable files in Eclipse
>> * Correctly saves preferences for the diagnostics window
>> * Correctly show bean getters/setters in mixed Java/Scala projects
>> * Performance improvements in structured selection
>> * New formatter preference window, with preview
>> * Format selection only
>> * Better memory usage when closing projects
>> * Allow compiler plugins in the presentation compiler
>> * other bug fixes
>>
>> There are 15 tickets fixed since the first beta. The complete list is
>> available here:
>>
>>
>> https://scala-ide-portfolio.assembla.com/spaces/ae55a-oWSr36hpeJe5avMc/t...
>>
>> You can install the new release by pointing Eclipse to the following
>> update site:
>> http://download.scala-ide.org/releases/wip_experiment-2.0.0-beta2
>
> There seems to be something wrong. I installed from this update site, but
> then got the "beta1". If you
> check the "site.xml" file, it also says "beta1".
> Lukas
>
>>
>> As the previous release, this one is built against the 2.9.0 branch of the
>> Scala compiler and requires at least Eclipse 3.6 (Helios)
>>
>> --
>> « Je déteste la montagne, ça cache le paysage »
>> Alphonse Allais
>
>

Copyright © 2012 École Polytechnique Fédérale de Lausanne (EPFL), Lausanne, Switzerland