This page is no longer maintained — Please continue to the home page at www.scala-lang.org

The Scala IDE for Eclipse for Scala 2.8.1.RC1 available now!

4 replies
milessabin
Joined: 2008-08-11,
User offline. Last seen 33 weeks 3 days ago.

I'm sure that everyone will join me in congratulating Martin and the
whole team at EPFL on the today's announcement of the first release
candidate of Scala 2.8.1,

http://www.scala-lang.org/node/7550

To match this, a new build of the Scala IDE for Eclipse is now
available for update or download,

http://download.scala-ide.org/

Note that the release cycles for the main Scala toolchain and for the
IDE are less tightly coupled than they have been in the past. This
means that you can continue to follow the development of the IDE
whilst working with the stable Scala toolchain release that you build
your projects with: separate update sites are available for all the
supported toolchain releases, and well as the Scala toolchain trunk.

Cheers,

Miles

phkoester
Joined: 2009-08-23,
User offline. Last seen 42 years 45 weeks ago.
Re: The Scala IDE for Eclipse for Scala 2.8.1.RC1 available now

> To match this, a new build of the Scala IDE for Eclipse is now
> available for update or download,
>
> http://download.scala-ide.org/

I'm trying to install Scala IDE from

http://download.scala-ide.org/nightly-update-master-2.8.1.RC1

and get this:

Your original request has been modified.
"Dummy weaving feature for upgrade" will be ignored because a newer
version is already installed.
Cannot complete the install because of a conflicting dependency.
Software being installed: JDT Weaving for Scala 1.0.0.201010010312
(org.scala-ide.sdt.weaving.feature.feature.group 1.0.0.201010010312)
Software currently installed: AspectJ Development Tools
2.1.0.e35x-release-20100630-1500 (org.eclipse.ajdt.feature.group
2.1.0.e35x-release-20100630-1500)
Only one of the following can be installed at once:
JDT Weaving 2.1.0.e35x-release-20100630-1500
(org.eclipse.contribution.weaving.jdt 2.1.0.e35x-release-20100630-1500)
JDT Weaving 2.1.1.e35x-20100903-1400
(org.eclipse.contribution.weaving.jdt 2.1.1.e35x-20100903-1400)
Cannot satisfy dependency:
From: AspectJ Development Tools 2.1.0.e35x-release-20100630-1500
(org.eclipse.ajdt.feature.group 2.1.0.e35x-release-20100630-1500)
To: org.eclipse.contribution.weaving.jdt
[2.1.0.e35x-release-20100630-1500]
Cannot satisfy dependency:
From: JDT Weaving for Scala 1.0.0.201010010312
(org.scala-ide.sdt.weaving.feature.feature.group 1.0.0.201010010312)
To: org.eclipse.contribution.weaving.jdt [2.1.1.e35x-20100903-1400]

Do I have to uninstall/reinstall AJDT somehow? I still work with Eclipse
3.5, and my AJDT update site is
http://download.eclipse.org/tools/ajdt/35/update.

Regards
--Phil

phkoester
Joined: 2009-08-23,
User offline. Last seen 42 years 45 weeks ago.
Re: The Scala IDE for Eclipse for Scala 2.8.1.RC1 available now

> To match this, a new build of the Scala IDE for Eclipse is now
> available for update or download,
>
> http://download.scala-ide.org/

I'm trying to install Scala IDE from

http://download.scala-ide.org/nightly-update-master-2.8.1.RC1

and get this:

Your original request has been modified.
"Dummy weaving feature for upgrade" will be ignored because a newer
version is already installed.
Cannot complete the install because of a conflicting dependency.
Software being installed: JDT Weaving for Scala 1.0.0.201010010312
(org.scala-ide.sdt.weaving.feature.feature.group 1.0.0.201010010312)
Software currently installed: AspectJ Development Tools
2.1.0.e35x-release-20100630-1500 (org.eclipse.ajdt.feature.group
2.1.0.e35x-release-20100630-1500)
Only one of the following can be installed at once:
JDT Weaving 2.1.0.e35x-release-20100630-1500
(org.eclipse.contribution.weaving.jdt 2.1.0.e35x-release-20100630-1500)
JDT Weaving 2.1.1.e35x-20100903-1400
(org.eclipse.contribution.weaving.jdt 2.1.1.e35x-20100903-1400)
Cannot satisfy dependency:
From: AspectJ Development Tools 2.1.0.e35x-release-20100630-1500
(org.eclipse.ajdt.feature.group 2.1.0.e35x-release-20100630-1500)
To: org.eclipse.contribution.weaving.jdt
[2.1.0.e35x-release-20100630-1500]
Cannot satisfy dependency:
From: JDT Weaving for Scala 1.0.0.201010010312
(org.scala-ide.sdt.weaving.feature.feature.group 1.0.0.201010010312)
To: org.eclipse.contribution.weaving.jdt [2.1.1.e35x-20100903-1400]

Do I have to uninstall/reinstall AJDT somehow? I still work with Eclipse
3.5, and my AJDT update site is
http://download.eclipse.org/tools/ajdt/35/update.

Regards
--Phil

david.bernard
Joined: 2009-01-08,
User offline. Last seen 1 year 27 weeks ago.
Re: The Scala IDE for Eclipse for Scala 2.8.1.RC1 available now
Philip,
If you have AJDT installed, you should not install JDT weaving from Scala-IDE.If you don't need full AJDT, then uninstall it (fully) and install Scala-IDE and JDT weaving from scala-ide update site.
/davidB

On Fri, Oct 1, 2010 at 22:45, Philip Köster <philip [dot] koester [at] web [dot] de> wrote:
To match this, a new build of the Scala IDE for Eclipse is now
available for update or download,

  http://download.scala-ide.org/

I'm trying to install Scala IDE from

http://download.scala-ide.org/nightly-update-master-2.8.1.RC1

and get this:

Your original request has been modified.
 "Dummy weaving feature for upgrade" will be ignored because a newer version is already installed.
Cannot complete the install because of a conflicting dependency.
 Software being installed: JDT Weaving for Scala 1.0.0.201010010312 (org.scala-ide.sdt.weaving.feature.feature.group 1.0.0.201010010312)
 Software currently installed: AspectJ Development Tools 2.1.0.e35x-release-20100630-1500 (org.eclipse.ajdt.feature.group 2.1.0.e35x-release-20100630-1500)
 Only one of the following can be installed at once:
   JDT Weaving 2.1.0.e35x-release-20100630-1500 (org.eclipse.contribution.weaving.jdt 2.1.0.e35x-release-20100630-1500)
   JDT Weaving 2.1.1.e35x-20100903-1400 (org.eclipse.contribution.weaving.jdt 2.1.1.e35x-20100903-1400)
 Cannot satisfy dependency:
   From: AspectJ Development Tools 2.1.0.e35x-release-20100630-1500 (org.eclipse.ajdt.feature.group 2.1.0.e35x-release-20100630-1500)
   To: org.eclipse.contribution.weaving.jdt [2.1.0.e35x-release-20100630-1500]
 Cannot satisfy dependency:
   From: JDT Weaving for Scala 1.0.0.201010010312 (org.scala-ide.sdt.weaving.feature.feature.group 1.0.0.201010010312)
   To: org.eclipse.contribution.weaving.jdt [2.1.1.e35x-20100903-1400]

Do I have to uninstall/reinstall AJDT somehow? I still work with Eclipse 3.5, and my AJDT update site is http://download.eclipse.org/tools/ajdt/35/update.

Regards
--Phil

david.bernard
Joined: 2009-01-08,
User offline. Last seen 1 year 27 weeks ago.
Re: The Scala IDE for Eclipse for Scala 2.8.1.RC1 available now
Philip,
If you have AJDT installed, you should not install JDT weaving from Scala-IDE.If you don't need full AJDT, then uninstall it (fully) and install Scala-IDE and JDT weaving from scala-ide update site.
/davidB

On Fri, Oct 1, 2010 at 22:45, Philip Köster <philip [dot] koester [at] web [dot] de> wrote:
To match this, a new build of the Scala IDE for Eclipse is now
available for update or download,

  http://download.scala-ide.org/

I'm trying to install Scala IDE from

http://download.scala-ide.org/nightly-update-master-2.8.1.RC1

and get this:

Your original request has been modified.
 "Dummy weaving feature for upgrade" will be ignored because a newer version is already installed.
Cannot complete the install because of a conflicting dependency.
 Software being installed: JDT Weaving for Scala 1.0.0.201010010312 (org.scala-ide.sdt.weaving.feature.feature.group 1.0.0.201010010312)
 Software currently installed: AspectJ Development Tools 2.1.0.e35x-release-20100630-1500 (org.eclipse.ajdt.feature.group 2.1.0.e35x-release-20100630-1500)
 Only one of the following can be installed at once:
   JDT Weaving 2.1.0.e35x-release-20100630-1500 (org.eclipse.contribution.weaving.jdt 2.1.0.e35x-release-20100630-1500)
   JDT Weaving 2.1.1.e35x-20100903-1400 (org.eclipse.contribution.weaving.jdt 2.1.1.e35x-20100903-1400)
 Cannot satisfy dependency:
   From: AspectJ Development Tools 2.1.0.e35x-release-20100630-1500 (org.eclipse.ajdt.feature.group 2.1.0.e35x-release-20100630-1500)
   To: org.eclipse.contribution.weaving.jdt [2.1.0.e35x-release-20100630-1500]
 Cannot satisfy dependency:
   From: JDT Weaving for Scala 1.0.0.201010010312 (org.scala-ide.sdt.weaving.feature.feature.group 1.0.0.201010010312)
   To: org.eclipse.contribution.weaving.jdt [2.1.1.e35x-20100903-1400]

Do I have to uninstall/reinstall AJDT somehow? I still work with Eclipse 3.5, and my AJDT update site is http://download.eclipse.org/tools/ajdt/35/update.

Regards
--Phil

Copyright © 2012 École Polytechnique Fédérale de Lausanne (EPFL), Lausanne, Switzerland