This page is no longer maintained — Please continue to the home page at www.scala-lang.org

Eclipse Update Site is unavailable

6 replies
Petr Gladkikh
Joined: 2009-01-20,
User offline. Last seen 42 years 45 weeks ago.

Hi.

I can not install Eclipse Scala plugin (neither
http://www.scala-lang.org/scala-eclipse-plugin and
http://www.scala-lang.org/scala-eclipse-plugin-nightly).

The web site either does not have appropriate files or permissions are
too restrictive.

Eclipse's error message is below:

An error occurred while collecting items to be installed
Problems downloading artifact: osgi.bundle,ch.epfl.lamp.sdt.core,2.7.3.RC2.
Exception connecting to
http://www.scala-lang.org/scala-eclipse-plugin/plugins/ch.epfl.lamp.sdt.....
http://www.scala-lang.org/scala-eclipse-plugin/plugins/ch.epfl.lamp.sdt....
Exception connecting to
http://www.scala-lang.org/scala-eclipse-plugin/plugins/ch.epfl.lamp.sdt.....
http://www.scala-lang.org/scala-eclipse-plugin/plugins/ch.epfl.lamp.sdt....
Error closing the output stream for
ch.epfl.lamp.sdt/org.eclipse.update.feature/2.7.3.RC2 on repository
file:/home/petr/opt/eclipse/.
Error unzipping /tmp/ch.epfl.lamp.sdt_2.7.3.RC264712.jar: Invalid
zip file format
Problems downloading artifact: osgi.bundle,scala.library,2.7.3.RC2.
Exception connecting to
http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.library_2.7....
http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.library_2.7...
Exception connecting to
http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.library_2.7....
http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.library_2.7...
Problems downloading artifact: osgi.bundle,scala.tools.nsc,2.7.3.RC2.
Exception connecting to
http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.tools.nsc_2....
http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.tools.nsc_2...
Exception connecting to
http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.tools.nsc_2....
http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.tools.nsc_2...

Antonio Cunei 2
Joined: 2008-12-20,
User offline. Last seen 42 years 45 weeks ago.
Re: Eclipse Update Site is unavailable

Petr,

We have had the current version available for a week, and we received no
reports of similar problems; I have just tried and all works here.

From your logs, it seems that Eclipse is trying to download 2.7.3.RC2, but
the files were replaced by 2.7.3.final, and Eclipse should see the new ones
instead. You may try to refresh your update site list in Eclipse, leaving
only the scala-eclipse-plugin site and removing the nightly one. Also, if
you have a previous version of the plugin installed, you can try to remove
it entirely before installing the new one.

If you still receive messages about the 2.7.3.RC2 after those steps, a
possibility might be that there is a proxy server of some sort on your
connection that is still serving some outdated files, or some caching that
is interfering with the Eclipse update mechanism; please look for

Miles Sabin might know a few additional tricks. If nothing works, you can
always perform an offline installation by manually downloading the eclipse
plugin archive, unzipping, and installing from there: the link is at
http://www.scala-lang.org/node/94

Toni

Petr Gladkikh wrote:
> Hi.
>
> I can not install Eclipse Scala plugin (neither
> http://www.scala-lang.org/scala-eclipse-plugin and
> http://www.scala-lang.org/scala-eclipse-plugin-nightly).
>
> The web site either does not have appropriate files or permissions are
> too restrictive.
>
> Eclipse's error message is below:
>
> An error occurred while collecting items to be installed
> Problems downloading artifact: osgi.bundle,ch.epfl.lamp.sdt.core,2.7.3.RC2.
> Exception connecting to
> http://www.scala-lang.org/scala-eclipse-plugin/plugins/ch.epfl.lamp.sdt.....
> http://www.scala-lang.org/scala-eclipse-plugin/plugins/ch.epfl.lamp.sdt....
> Exception connecting to
> http://www.scala-lang.org/scala-eclipse-plugin/plugins/ch.epfl.lamp.sdt.....
> http://www.scala-lang.org/scala-eclipse-plugin/plugins/ch.epfl.lamp.sdt....
> Error closing the output stream for
> ch.epfl.lamp.sdt/org.eclipse.update.feature/2.7.3.RC2 on repository
> file:/home/petr/opt/eclipse/.
> Error unzipping /tmp/ch.epfl.lamp.sdt_2.7.3.RC264712.jar: Invalid
> zip file format
> Problems downloading artifact: osgi.bundle,scala.library,2.7.3.RC2.
> Exception connecting to
> http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.library_2.7....
> http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.library_2.7...
> Exception connecting to
> http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.library_2.7....
> http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.library_2.7...
> Problems downloading artifact: osgi.bundle,scala.tools.nsc,2.7.3.RC2.
> Exception connecting to
> http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.tools.nsc_2....
> http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.tools.nsc_2...
> Exception connecting to
> http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.tools.nsc_2....
> http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.tools.nsc_2...
>

Sean McDirmid
Joined: 2008-12-17,
User offline. Last seen 42 years 45 weeks ago.
Re: Eclipse Update Site is unavailable
Sounds like a proxy caching problem to me. I'd try to load the update site in your browser manually and hit refresh from there, and then afterwards try to update from Eclipse again. 

On Tue, Jan 20, 2009 at 5:30 PM, Antonio Cunei <scala_ml [at] cunei [dot] com> wrote:
Petr,

We have had the current version available for a week, and we received no reports of similar problems; I have just tried and all works here.

From your logs, it seems that Eclipse is trying to download 2.7.3.RC2, but the files were replaced by 2.7.3.final, and Eclipse should see the new ones instead. You may try to refresh your update site list in Eclipse, leaving only the scala-eclipse-plugin site and removing the nightly one. Also, if you have a previous version of the plugin installed, you can try to remove it entirely before installing the new one.

If you still receive messages about the 2.7.3.RC2 after those steps, a possibility might be that there is a proxy server of some sort on your connection that is still serving some outdated files, or some caching that is interfering with the Eclipse update mechanism; please look for

Miles Sabin might know a few additional tricks. If nothing works, you can always perform an offline installation by manually downloading the eclipse plugin archive, unzipping, and installing from there: the link is at http://www.scala-lang.org/node/94

Toni


Petr Gladkikh wrote:
Hi.

I can not install Eclipse Scala plugin (neither
http://www.scala-lang.org/scala-eclipse-plugin and
http://www.scala-lang.org/scala-eclipse-plugin-nightly).

The web site either does not have appropriate files or permissions are
too restrictive.

Eclipse's error message is below:

An error occurred while collecting items to be installed
 Problems downloading artifact: osgi.bundle,ch.epfl.lamp.sdt.core,2.7.3.RC2.
..3.RC2.
   Exception connecting to
http://www.scala-lang.org/scala-eclipse-plugin/plugins/ch.epfl.lamp.sdt.core_2.7.3.RC2.jar.
   http://www.scala-lang.org/scala-eclipse-plugin/plugins/ch.epfl.lamp.sdt.core_2.7.3.RC2.jar
   Exception connecting to
http://www.scala-lang.org/scala-eclipse-plugin/plugins/ch.epfl.lamp.sdt.core_2.7.3.RC2.jar.
   http://www.scala-lang.org/scala-eclipse-plugin/plugins/ch.epfl.lamp.sdt.core_2.7.3.RC2.jar
 Error closing the output stream for
ch.epfl.lamp.sdt/org.eclipse.update.feature/2.7.3.RC2 on repository
file:/home/petr/opt/eclipse/.
 Error unzipping /tmp/ch.epfl.lamp.sdt_2.7.3.RC264712.jar: Invalid
zip file format
 Problems downloading artifact: osgi.bundle,scala.library,2.7.3.RC2.
   Exception connecting to
http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.library_2.7.3.RC2.jar.
   http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.library_2.7.3.RC2.jar
   Exception connecting to
http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.library_2.7.3.RC2.jar.
   http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.library_2.7.3.RC2.jar
 Problems downloading artifact: osgi.bundle,scala.tools.nsc,2.7.3.RC2.
..
   Exception connecting to
http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.tools.nsc_2.7.3.RC2.jar.
   http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.tools.nsc_2.7.3.RC2.jar
..org/scala-eclipse-plugin/plugins/scala.tools.nsc_2.7.3.RC2.jar
   Exception connecting to
http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.tools.nsc_2.7.3.RC2.jar.
   http://www.scala-lang.org/scala-eclipse-plugin/plugins/scala.tools.nsc_2.7.3.RC2.jar
..org/scala-eclipse-plugin/plugins/scala.tools.nsc_2.7.3.RC2.jar



Antonio Cunei 2
Joined: 2008-12-20,
User offline. Last seen 42 years 45 weeks ago.
Re: Eclipse Update Site is unavailable

Sean McDirmid wrote:
> Sounds like a proxy caching problem to me. I'd try to load the update site
> in your browser manually and hit refresh from there, and then afterwards try
> to update from Eclipse again.
>

The update site won't load manually from a browser, there is no index.html
or any default page to show. However, loading (and refreshing) this will work:

http://www.scala-lang.org/scala-eclipse-plugin/site.xml

(check with View Source to make sure that the loaded file contains
"2.7.3.final")
Toni

milessabin
Joined: 2008-08-11,
User offline. Last seen 33 weeks 3 days ago.
Re: Eclipse Update Site is unavailable

On Tue, Jan 20, 2009 at 9:30 AM, Antonio Cunei wrote:
> Miles Sabin might know a few additional tricks.

The main thing to try is to remove and reinstate the Scala update site
from the update manager ... I believe there's an open Eclipse bug
relating to this.

Cheers,

Miles

Sean McDirmid
Joined: 2008-12-17,
User offline. Last seen 42 years 45 weeks ago.
Re: Eclipse Update Site is unavailable
Also, are you doing update or re-install? I don't think "update" works very well, if you just go to "Search for new plugins" on the scala update site, that works much better for installing a new version. 

On Tue, Jan 20, 2009 at 6:03 PM, Antonio Cunei <scala_ml [at] cunei [dot] com> wrote:
Sean McDirmid wrote:
Sounds like a proxy caching problem to me. I'd try to load the update site
in your browser manually and hit refresh from there, and then afterwards try
to update from Eclipse again.


The update site won't load manually from a browser, there is no index.html or any default page to show. However, loading (and refreshing) this will work:

http://www.scala-lang.org/scala-eclipse-plugin/site.xml

(check with View Source to make sure that the loaded file contains "2.7.3.final")
Toni


Petr Gladkikh
Joined: 2009-01-20,
User offline. Last seen 42 years 45 weeks ago.
Re: Eclipse Update Site is unavailable

Thank you for your hints.

I have already installed it offline (by guessing what JAR URL for
2.7.3 would be :)
I turned out to be a HTTP proxy problem (after explicitly refreshing
site.xml in browser RC reference was replaced by "final" URL).

On Tue, Jan 20, 2009 at 4:14 PM, Sean McDirmid wrote:
> Also, are you doing update or re-install? I don't think "update" works very
> well, if you just go to "Search for new plugins" on the scala update site,
> that works much better for installing a new version.
>
> On Tue, Jan 20, 2009 at 6:03 PM, Antonio Cunei wrote:
>>
>> Sean McDirmid wrote:
>>>
>>> Sounds like a proxy caching problem to me. I'd try to load the update
>>> site
>>> in your browser manually and hit refresh from there, and then afterwards
>>> try
>>> to update from Eclipse again.
>>>
>>
>> The update site won't load manually from a browser, there is no index.html
>> or any default page to show. However, loading (and refreshing) this will
>> work:
>>
>> http://www.scala-lang.org/scala-eclipse-plugin/site.xml
>>
>> (check with View Source to make sure that the loaded file contains
>> "2.7.3.final")
>> Toni

Copyright © 2012 École Polytechnique Fédérale de Lausanne (EPFL), Lausanne, Switzerland