This page is no longer maintained — Please continue to the home page at www.scala-lang.org

Cannot Build Scala Eclipse Plugin on Windows Vista x64

4 replies
Bret Lester
Joined: 2009-01-10,
User offline. Last seen 42 years 45 weeks ago.

I'm getting an IOException while running the devel.prep Ant build
target as described here:
http://lampsvn.epfl.ch/trac/scala/wiki/EclipsePlugin#Preparation

The specific IOException message is this:
java.io.IOException: Cannot run program "C:\Program
Files\Java\jdk1.6.0_11\jre\bin\java.exe" (in directory
"C:\Users\Bret\workspace\scala\scala"): CreateProcess error=87, The
parameter is incorrect

After some google searches it seems this error is often associated
with the classpath being too long on Windows systems (which seems
likely since the build completes just fine on my MacBook). Any info as
to how to resolve this would be appreciated. Ive attached the full
console output from the build.

Thanks!
Bret L.

Sean McDirmid
Joined: 2008-12-17,
User offline. Last seen 42 years 45 weeks ago.
Re: Cannot Build Scala Eclipse Plugin on Windows Vista x64
Maybe you have spaces in your classpath? 

On Sun, Jan 11, 2009 at 6:03 AM, Bret Lester <bret [at] bretlester [dot] com> wrote:
I'm getting an IOException while running the devel.prep Ant build
target as described here:
http://lampsvn.epfl.ch/trac/scala/wiki/EclipsePlugin#Preparation

The specific IOException message is this:
 java.io.IOException: Cannot run program "C:\Program
Files\Java\jdk1.6.0_11\jre\bin\java.exe" (in directory
"C:\Users\Bret\workspace\scala\scala"): CreateProcess error=87, The
parameter is incorrect

After some google searches it seems this error is often associated
with the classpath being too long on Windows systems (which seems
likely since the build completes just fine on my MacBook). Any info as
to how to resolve this would be appreciated. Ive attached the full
console output from the build.

Thanks!
Bret L.

Sean McDirmid
Joined: 2008-12-17,
User offline. Last seen 42 years 45 weeks ago.
Re: Cannot Build Scala Eclipse Plugin on Windows Vista x64
Maybe you have spaces in your classpath? 

On Sun, Jan 11, 2009 at 6:03 AM, Bret Lester <bret [at] bretlester [dot] com> wrote:
I'm getting an IOException while running the devel.prep Ant build
target as described here:
http://lampsvn.epfl.ch/trac/scala/wiki/EclipsePlugin#Preparation

The specific IOException message is this:
 java.io.IOException: Cannot run program "C:\Program
Files\Java\jdk1.6.0_11\jre\bin\java.exe" (in directory
"C:\Users\Bret\workspace\scala\scala"): CreateProcess error=87, The
parameter is incorrect

After some google searches it seems this error is often associated
with the classpath being too long on Windows systems (which seems
likely since the build completes just fine on my MacBook). Any info as
to how to resolve this would be appreciated. Ive attached the full
console output from the build.

Thanks!
Bret L.

Joshua.Suereth
Joined: 2008-09-02,
User offline. Last seen 32 weeks 5 days ago.
Re: Cannot Build Scala Eclipse Plugin on Windows Vista x64
We just ran into this issue with the maven-scala-plugin.  It looks like scalac will need to support something like @files, and then we need to update the tools to use that.
For now, try hanging the scala root directory somewhere near a true root (Mine is C:\Projects\scala, but I'm using XP)

Sent from my iPhone
On Jan 10, 2009, at 7:45 PM, "Sean McDirmid" <sean [dot] mcdirmid [at] gmail [dot] com> wrote:

Maybe you have spaces in your classpath? 

On Sun, Jan 11, 2009 at 6:03 AM, Bret Lester <bret [at] bretlester [dot] com (bret [at] bretlester [dot] com" rel="nofollow">bret [at] bretlester [dot] com)> wrote:
I'm getting an IOException while running the devel.prep Ant build
target as described here:
http://lampsvn.epfl.ch/trac/scala/wiki/EclipsePlugin#Preparation

The specific IOException message is this:
 java.io.IOException: Cannot run program "C:\Program
Files\Java\jdk1.6.0_11\jre\bin\java.exe" (in directory
"C:\Users\Bret\workspace\scala\scala"): CreateProcess error=87, The
parameter is incorrect

After some google searches it seems this error is often associated
with the classpath being too long on Windows systems (which seems
likely since the build completes just fine on my MacBook). Any info as
to how to resolve this would be appreciated. Ive attached the full
console output from the build.

Thanks!
Bret L.

Bret Lester
Joined: 2009-01-10,
User offline. Last seen 42 years 45 weeks ago.
Re: Cannot Build Scala Eclipse Plugin on Windows Vista x64

Moving the scala root did the trick for now! Thanks

B.L.

On Sat, Jan 10, 2009 at 6:08 PM, Josh Suereth wrote:
> We just ran into this issue with the maven-scala-plugin. It looks like
> scalac will need to support something like @files, and then we need to
> update the tools to use that.
> For now, try hanging the scala root directory somewhere near a true root
> (Mine is C:\Projects\scala, but I'm using XP)
>
> Sent from my iPhone
> On Jan 10, 2009, at 7:45 PM, "Sean McDirmid"
> wrote:
>
> Maybe you have spaces in your classpath?
>
> On Sun, Jan 11, 2009 at 6:03 AM, Bret Lester wrote:
>>
>> I'm getting an IOException while running the devel.prep Ant build
>> target as described here:
>> http://lampsvn.epfl.ch/trac/scala/wiki/EclipsePlugin#Preparation
>>
>> The specific IOException message is this:
>> java.io.IOException: Cannot run program "C:\Program
>> Files\Java\jdk1.6.0_11\jre\bin\java.exe" (in directory
>> "C:\Users\Bret\workspace\scala\scala"): CreateProcess error=87, The
>> parameter is incorrect
>>
>> After some google searches it seems this error is often associated
>> with the classpath being too long on Windows systems (which seems
>> likely since the build completes just fine on my MacBook). Any info as
>> to how to resolve this would be appreciated. Ive attached the full
>> console output from the build.
>>
>> Thanks!
>> Bret L.
>
>

Copyright © 2012 École Polytechnique Fédérale de Lausanne (EPFL), Lausanne, Switzerland