This page is no longer maintained — Please continue to the home page at www.scala-lang.org

"Syntax error on tokens, ClassHeader expected instead" with latest eclipse nightly

3 replies
Kevin Wright
Joined: 2009-06-09,
User offline. Last seen 49 weeks 3 days ago.
Here's the entire scala file(in fact, it's the entire program so far...)

package org.thecoda.finance
object Main {  def main(args : Array[String]) : Unit = {} }

And that error is occuring on line 1 (the package specifier)I also get syntax errors against `String` and `:`I'm running eclipse 3.5.1 against java 1.6.0_17 on OSX snow leopard
Any ideas?

--
Kevin Wright

mail/google talk: kev [dot] lee [dot] wright [at] googlemail [dot] com
wave: kev [dot] lee [dot] wright [at] googlewave [dot] com
skype: kev.lee.wright
twitter: @thecoda

milessabin
Joined: 2008-08-11,
User offline. Last seen 33 weeks 3 days ago.
Re: "Syntax error on tokens, ClassHeader expected instead" wit

On Fri, Jan 8, 2010 at 1:01 PM, Kevin Wright
wrote:
> Here's the entire scala file
> (in fact, it's the entire program so far...)
>
> package org.thecoda.finance
> object Main {
>   def main(args : Array[String]) : Unit = {}
> }
>
> And that error is occuring on line 1 (the package specifier)
> I also get syntax errors against `String` and `:`
> I'm running eclipse 3.5.1 against java 1.6.0_17 on OSX snow leopard
> Any ideas?

That's an error from the Java compiler (I expect you can see "Java
Problem" next to it in the Problems View, so it looks like your
installation is messed up somehow.

Cheers,

Miles

Kevin Wright
Joined: 2009-06-09,
User offline. Last seen 49 weeks 3 days ago.
Re: "Syntax error on tokens, ClassHeader expected instead" wit
looks like JDT aspect weaving, but it refuses to enable for some reasonDoes anyone know of this as an issue with OSX?  I'm sure I read about something similar a while back...


2010/1/8 Miles Sabin <miles [at] milessabin [dot] com>
On Fri, Jan 8, 2010 at 1:01 PM, Kevin Wright
<kev [dot] lee [dot] wright [at] googlemail [dot] com> wrote:
> Here's the entire scala file
> (in fact, it's the entire program so far...)
>
> package org.thecoda.finance
> object Main {
>   def main(args : Array[String]) : Unit = {}
> }
>
> And that error is occuring on line 1 (the package specifier)
> I also get syntax errors against `String` and `:`
> I'm running eclipse 3.5.1 against java 1.6.0_17 on OSX snow leopard
> Any ideas?

That's an error from the Java compiler (I expect you can see "Java
Problem" next to it in the Problems View, so it looks like your
installation is messed up somehow.

Cheers,


Miles

--
Miles Sabin
tel: +44 (0)7813 944 528
skype:  milessabin
http://www.chuusai.com/
http://twitter.com/milessabin



--
Kevin Wright

mail/google talk: kev [dot] lee [dot] wright [at] googlemail [dot] com
wave: kev [dot] lee [dot] wright [at] googlewave [dot] com
skype: kev.lee.wright
twitter: @thecoda

Kevin Wright
Joined: 2009-06-09,
User offline. Last seen 49 weeks 3 days ago.
Re: "Syntax error on tokens, ClassHeader expected instead" wit
curiouser and curiouser
I followed the instructions here:http://wiki.eclipse.org/JDT_weaving_features
according to the plug-in registry view, weaving is enabled the bundles.info file says the same thing

but the UI under preferences continues to tell me that weaving is DISABLED

Got some serious head-scratching now taking place

2010/1/8 Kevin Wright <kev [dot] lee [dot] wright [at] googlemail [dot] com>
looks like JDT aspect weaving, but it refuses to enable for some reasonDoes anyone know of this as an issue with OSX?  I'm sure I read about something similar a while back...


2010/1/8 Miles Sabin <miles [at] milessabin [dot] com>
On Fri, Jan 8, 2010 at 1:01 PM, Kevin Wright
<kev [dot] lee [dot] wright [at] googlemail [dot] com> wrote:
> Here's the entire scala file
> (in fact, it's the entire program so far...)
>
> package org.thecoda.finance
> object Main {
>   def main(args : Array[String]) : Unit = {}
> }
>
> And that error is occuring on line 1 (the package specifier)
> I also get syntax errors against `String` and `:`
> I'm running eclipse 3.5.1 against java 1.6.0_17 on OSX snow leopard
> Any ideas?

That's an error from the Java compiler (I expect you can see "Java
Problem" next to it in the Problems View, so it looks like your
installation is messed up somehow.

Cheers,


Miles

--
Miles Sabin
tel: +44 (0)7813 944 528
skype:  milessabin
http://www.chuusai.com/
http://twitter.com/milessabin



--
Kevin Wright

mail/google talk: kev [dot] lee [dot] wright [at] googlemail [dot] com
wave: kev [dot] lee [dot] wright [at] googlewave [dot] com
skype: kev.lee.wright
twitter: @thecoda




--
Kevin Wright

mail/google talk: kev [dot] lee [dot] wright [at] googlemail [dot] com
wave: kev [dot] lee [dot] wright [at] googlewave [dot] com
skype: kev.lee.wright
twitter: @thecoda

Copyright © 2012 École Polytechnique Fédérale de Lausanne (EPFL), Lausanne, Switzerland