This page is no longer maintained — Please continue to the home page at www.scala-lang.org

2.7.7 or 2.8.x for new Eclipse Scala project?

2 replies
Blair Zajac
Joined: 2009-01-12,
User offline. Last seen 42 years 45 weeks ago.

One of the developers on my team is a very strong Eclipse programmer and
isn't too excited about using Scala on a brand new project due to the
weaker Eclipse IDE support compared to Java or Groovy. He would rather
work in Java or Groovy since the IDE support is much stronger.

Given this is a brand new project and the his most important concern is
IDE support, which version of the Eclipse Scala plugin should we use?
2.8.x line or the 2.7.x?

I'm not too concerned with coding against Scala 2.8.x since the API is
pretty stable and given the code base is small, recompiling it for newer
2.8.x beta releases isn't a big deal.

Is the Eclipse 2.8 support a significant step better than the 2.7?

Thanks,
Blair

nilskp
Joined: 2009-01-30,
User offline. Last seen 1 year 27 weeks ago.
Re: 2.7.7 or 2.8.x for new Eclipse Scala project?
On Thu, Jan 7, 2010 at 12:22 PM, Blair Zajac <blair [at] orcaware [dot] com> wrote:
Is the Eclipse 2.8 support a significant step better than the 2.7?

YES!
Blair Zajac
Joined: 2009-01-12,
User offline. Last seen 42 years 45 weeks ago.
Re: 2.7.7 or 2.8.x for new Eclipse Scala project?

On 01/07/2010 10:41 AM, Nils Kilden-Pedersen wrote:
> On Thu, Jan 7, 2010 at 12:22 PM, Blair Zajac > wrote:
>
> Is the Eclipse 2.8 support a significant step better than the 2.7?
> YES!

Great, thanks! I'm an Emacs user so don't use Eclipse on a daily basis.
Plus my Scala project is 40,000+ lines of 2.7.7 code which would take
a good deal of refactoring to use 2.8.x.

Blair

Copyright © 2012 École Polytechnique Fédérale de Lausanne (EPFL), Lausanne, Switzerland