This page is no longer maintained — Please continue to the home page at

RE: Scala IDE install cannot complete because of a conflicting dependency

No replies
Naftoli Gugenheim
Joined: 2008-12-17,
User offline. Last seen 42 years 45 weeks ago.

In other words you have to uninstall AspectJ and download the archive of the compatible version and install that.

Daffin, Miles wrote:

Hi Miles,

Will this release be in the nightly build update site?



-----Original Message-----
From: Miles Sabin [mailto:miles [at] milessabin [dot] com]
Sent: 05 August 2009 14:27
To: Daffin, Miles (IDEAS)
Cc: scala-tools [at] listes [dot] epfl [dot] ch; Thomas Hallgren
Subject: Re: [scala-tools] Scala IDE install cannot complete because of a conflicting dependency

On Wed, Aug 5, 2009 at 1:49 PM, Daffin,
Miles wrote:
> I cannot install the latest version of the Scala IDE because I also
> have the latest version of the Aspect J Dev Tools installed, which
> comes with a more recent version of the
> org.eclipse.equinox.weaving.aspectj feature than the one that the
> Scala feature depends on. This feature is a singleton, meaning that only one version can be installed at any one time. Here is the error:

This is fixed on trunk, which I appreciate might not be all that helpful to you right now. should be compatible with AJDT 1.6.4/Eclipse 3.4.2 and with AJDT 1.7.0/Eclipse 3.5. I'm afraid all my bandwidth is taken up with work for 2.8.0, so the chances of there being an intermediate release are extremely slim.



Miles Sabin
tel: +44 (0)7813 944 528
skype: milessabin

NOTICE: If received in error, please destroy, and notify sender. Sender does not intend to waive confidentiality or privilege. Use of this email is prohibited when received in error. We may monitor and store emails to the extent permitted by applicable law.

Copyright © 2012 École Polytechnique Fédérale de Lausanne (EPFL), Lausanne, Switzerland