This page is no longer maintained — Please continue to the home page at www.scala-lang.org

2.7.4 and 2.8 object code compatibility?

2 replies
tim.pigden
Joined: 2009-04-30,
User offline. Last seen 1 year 4 weeks ago.

Hi

I’m getting the following error trying to run something with 2.8

I’m using scalajpa which has been compiled for 2.7.4

>>>>>>> 

[ERROR] C:\programmingExperiments\scala\domains\al2\src\main\scala\..\scala

[INFO] Compiling 38 source files to C:\programmingExperiments\scala\domains\al2\target\classes

[WARNING] Exception in thread "main" java.lang.RuntimeException: malformed Scala signature of ScalaEntityManager at 2752; reference value jcl of package collection refers to nonexisting symbol.

[WARNING]       at scala.tools.nsc.symtab.classfile.UnPickler$UnPickle.errorBadSignature(UnPickler.scala:760)

[WARNING]       at scala.tools.nsc.symtab.classfile.UnPickler$UnPickle.scala$tools$nsc$symtab$classfile$UnPickler$UnPickle$$readSymbol(UnPickler.scala:172)

[WARNING]

>>>>>>> 

Does this mean that I need to recompile any stuff I use against 2.8 explicitly?

 

Tim

odersky
Joined: 2008-07-29,
User offline. Last seen 45 weeks 6 days ago.
Re: 2.7.4 and 2.8 object code compatibility?

On Sat, May 9, 2009 at 1:01 PM, Tim Pigden wrote:
> Hi
>
> I’m getting the following error trying to run something with 2.8
>
> I’m using scalajpa which has been compiled for 2.7.4
>
>>>>>>>>
>
> [ERROR] C:\programmingExperiments\scala\domains\al2\src\main\scala\..\scala
>
> [INFO] Compiling 38 source files to
> C:\programmingExperiments\scala\domains\al2\target\classes
>
> [WARNING] Exception in thread "main" java.lang.RuntimeException: malformed
> Scala signature of ScalaEntityManager at 2752; reference value jcl of
> package collection refers to nonexisting symbol.
>
> [WARNING]       at
> scala.tools.nsc.symtab.classfile.UnPickler$UnPickle.errorBadSignature(UnPickler.scala:760)
>
> [WARNING]       at
> scala.tools.nsc.symtab.classfile.UnPickler$UnPickle.scala$tools$nsc$symtab$classfile$UnPickler$UnPickle$$readSymbol(UnPickler.scala:172)
>
> [WARNING]
>
>>>>>>>>
>
> Does this mean that I need to recompile any stuff I use against 2.8
> explicitly?
>
Yes. We are in the middle of transitioning to the new collections
library. Expect nightly builds to be less stable and functional for a
while than usual.

Cheers

Joshua.Suereth
Joined: 2008-09-02,
User offline. Last seen 32 weeks 5 days ago.
Re: 2.7.4 and 2.8 object code compatibility?
Yes, scala versions must match.  As long as libraries do not mark scala as a "provided" dependency, the maven-scala-plugin should detect mismatch and issue an error.

Sent from my iPhone
On May 9, 2009, at 7:01 AM, "Tim Pigden" <tim [dot] pigden [at] optrak [dot] co [dot] uk> wrote:

Hi

I’m getting the following error trying to run something with 2.8

I’m using scalajpa which has been compiled for 2.7.4

>>>>>>> 

[ERROR] C:\programmingExperiments\scala\domains\al2\src\main\scala\..\scala

[INFO] Compiling 38 source files to C:\programmingExperiments\scala\domains\al2\target\classes

[WARNING] Exception in thread "main" java.lang.RuntimeException: malformed Scala signature of ScalaEntityManager at 2752; reference value jcl of package collection refers to nonexisting symbol.

[WARNING]       at scala.tools.nsc.symtab.classfile.UnPickler$UnPickle.errorBadSignature(UnPickler.scala:760)

[WARNING]       at scala.tools.nsc.symtab.classfile.UnPickler$UnPickle.scala$tools$nsc$symtab$classfile$UnPickler$UnPickle$$readSymbol(UnPickler.scala:172)

[WARNING]

>>>>>>> 

Does this mean that I need to recompile any stuff I use against 2.8 explicitly?

 

Tim

Copyright © 2012 École Polytechnique Fédérale de Lausanne (EPFL), Lausanne, Switzerland