This page is no longer maintained — Please continue to the home page at www.scala-lang.org

2.7.4-final plugin on Eclipse 3.4.2

2 replies
Stephen Magee
Joined: 2009-05-01,
User offline. Last seen 42 years 45 weeks ago.

Hi,

I've tried to install the 2.7.4.final plugin on Eclipse 3.4.2 but I'm getting
the following error:

Cannot complete the request. See the details.
Cannot find a solution satisfying the following requirements org.eclipse.swt
[3.4.1.v3449c].

I previously had the 2.7.3-final version installed which I uninstalled before
trying to install the new version (I can reinstall the 2.7.3-final version no
problem).

Does anyone have any ideas?

Thanks

Stephen

milessabin
Joined: 2008-08-11,
User offline. Last seen 33 weeks 3 days ago.
Re: 2.7.4-final plugin on Eclipse 3.4.2

On Fri, May 1, 2009 at 2:49 PM, Stephen Magee
wrote:
> I've tried to install the 2.7.4.final plugin on Eclipse 3.4.2 but I'm getting
> the following error:
>
> Cannot complete the request.  See the details.
> Cannot find a solution satisfying the following requirements org.eclipse.swt
> [3.4.1.v3449c].

That's very peculiar ... that version doesn't correspond to Eclipse
3.4.2, and the Scala IDE isn't requesting it.

Is this a fresh install of Eclipse? Do you have any other plugins installed?

Cheers,

Miles

Arthur Peters
Joined: 2009-01-09,
User offline. Last seen 42 years 45 weeks ago.
Re: 2.7.4-final plugin on Eclipse 3.4.2
I know this shouldn't effect anything, but I've found I have better luck doing upgrades and installs if I open a new empty workspace and do the installs/upgrades in that. I can then switch back to my normal workspace and things work fine.

Hope it helps.
-Arthur


On Fri, May 1, 2009 at 9:49 AM, Stephen Magee <stephen_magee [at] amt-sybex [dot] com> wrote:
Hi,

I've tried to install the 2.7.4.final plugin on Eclipse 3.4.2 but I'm getting
the following error:

Cannot complete the request.  See the details.
Cannot find a solution satisfying the following requirements org.eclipse.swt
[3.4.1.v3449c].

I previously had the 2.7.3-final version installed which I uninstalled before
trying to install the new version (I can reinstall the 2.7.3-final version no
problem).

Does anyone have any ideas?

Thanks

Stephen


Copyright © 2012 École Polytechnique Fédérale de Lausanne (EPFL), Lausanne, Switzerland