This page is no longer maintained — Please continue to the home page at

Eclipse IDE for Scala beta12 for Scala 2.9 and 2.8 is out

No replies
Eclipse Scala IDE
Joined: 2011-07-21,
User offline. Last seen 42 years 45 weeks ago.

We are happy to announce that the beta12 release of the Eclipse IDE for Scala is ready for download! This release comes in two flavors: the 2.9.2-SNAPSHOT version, and the 2.8.3-SNAPSHOT version.

The 2.8 compiler shipped with this version of the plugin is based on the development branch of 2.8.3, and is fully binary compatible with both 2.8.2 and 2.8.1. It contains the same improvements to the presentation compiler as the 2.9 version, and a number of bug fixes related to Java signatures. Also note that the 2.9.2-SNAPSHOT compiler shipped with this version of the plugin is fully binary compatile with both 2.9.1, 2.9.0-1 and 2.9.0.

What's new:

  • Hyperlinking on definitions between dependent projects works correctly.
  • For mixed Scala/Java project, allow to change sources' compilation order (i.e., first Java and then Scala, or the other way around).
  • Improved interoperability of mixed Scala/Java (#1000652#1000670#1000678).
  • Fixed a deadlock when the presentation compiler was awaken during builds.
  • Presentation compiler is notified of changes in dependent projects (no spurious errors after rebuild).
  • Fixed issue in the presentation compiler that caused implicit conversions not to be applied (#1000647).
  • Added classpath validator. An error is reported if the scala library is missing or the version is wrong (#1000631).
  • Improved refactoring (better support for organize/add imports). [by Mirko Stocker]
  • Wizard for creating Scala Application uses now trait _App_ instead of the deprecated _Application_ trait. [by Matt Russell]

A list of fixed tickets for this release is available here:

You can install the new release by pointing Eclipse to the following update site:

for the 2.9.2-SNAPSHOT version:

for the 2.8.3-SNAPSHOT version:

Other releases can be found at:

Both plugins are ensured to work with Eclipse 3.6 (Helios), which is currently the officially supported Eclipse platform for the Scala IDE. Support for Eclipse 3.7 (Indigo) is experimental.

Happy Scala coding!

-- The Eclipse Scala IDE Team

Copyright © 2012 École Polytechnique Fédérale de Lausanne (EPFL), Lausanne, Switzerland