This page is no longer maintained — Please continue to the home page at www.scala-lang.org

Problem compiling trunk from github: MissingRequirementError: class scala.reflect.BeanInfo not found.

1 reply
Ben Hutchison 3
Joined: 2009-11-02,
User offline. Last seen 42 years 45 weeks ago.

I have a fork of [https://github.com/scala/scala] which until
yesterday has been building ok with "ant". Then recently I git pulled
and started getting the following error during stage "quick.lib":

[scalacfork] error: scala.reflect.internal.MissingRequirementError:
class scala.reflect.BeanInfo not found.

It doesn't appear related to my changes. Has anyone else had this
problem? Any suggestions on how to resolve or what it means?

Thanks
Ben

Jason Zaugg
Joined: 2009-05-18,
User offline. Last seen 38 weeks 5 days ago.
Re: Problem compiling trunk from github: MissingRequirementErro
On Sun, Oct 16, 2011 at 6:56 AM, Ben Hutchison <brhutchison [at] gmail [dot] com> wrote:
I have a fork of [https://github.com/scala/scala] which until
yesterday has been building ok with "ant". Then recently I git pulled
and started getting the following error during stage "quick.lib":

[scalacfork] error: scala.reflect.internal.MissingRequirementError:
class scala.reflect.BeanInfo not found.

It doesn't appear related to my changes. Has anyone else had this
problem? Any suggestions on how to resolve or what it means?

It's likely that you need to rebuild your 'locker' layer, after some annotations where moved around.
Try `ant all.clean build`.
-jason

Copyright © 2012 École Polytechnique Fédérale de Lausanne (EPFL), Lausanne, Switzerland